C/C++经典实例之模拟计算器示例代码

前言

本文主要给大家介绍了关于利用C/C++如何实现模拟计算器的相关内容,分享出来供大家参考学习,下面话不多说了,来一起看看详细的介绍吧。

Problem Description

简单计算器模拟:输入两个整数和一个运算符,输出运算结果。

Input

第一行输入两个整数,用空格分开;

第二行输入一个运算符(+、-、*、/)。

所有运算均为整数运算,保证除数不包含0。

Output

输出对两个数运算后的结果。

Example Input

30 50

*

Example Output

import java.util.Scanner;

public class Main {

public static void main(String args[]){

Scanner reader = new Scanner(System.in);

int m,n;

String a = "+",b = "-",c="*",d = "/";

String s;

m = reader.nextInt();

n = reader.nextInt();

s = reader.next();

switch(s){

case"+":System.out.println(m+n);break;

case"-":System.out.println(m-n);break;

case"*":System.out.println(m*n);break;

case"/":

System.out.println(m/n);

break;

}

}

}

总结

以上是 C/C++经典实例之模拟计算器示例代码 的全部内容, 来源链接: utcz.com/z/361445.html

回到顶部