如何在Java中读取多行输入

我们的教授让我们用Java进行一些基本的编程,他提供了一个网站以及所有可以注册和提交问题的内容,因为今天我需要做一个例子,我觉得自己处在正确的轨道上,但是我无法找出其余的。这是实际的问题:

**Sample Input:**

10 12

10 14

100 200

**Sample Output:**

2

4

100

这是到目前为止我得到的:

public class Practice {

public static int calculateAnswer(String a, String b) {

return (Integer.parseInt(b) - Integer.parseInt(a));

}

public static void main(String[] args) {

System.out.println(calculateAnswer(args[0], args[1]));

}

}

现在,我总是会得到答案,2因为我正在阅读单行,如何考虑所有行?谢谢

由于某些奇怪的原因,每次我要执行时都会出现此错误:

C:\sonic>java Practice.class 10 12

Exception in thread "main" java.lang.NoClassDefFoundError: Fact

Caused by: java.lang.ClassNotFoundException: Fact.class

at java.net.URLClassLoader$1.run(URLClassLoader.java:20

at java.security.AccessController.doPrivileged(Native M

at java.net.URLClassLoader.findClass(URLClassLoader.jav

at java.lang.ClassLoader.loadClass(ClassLoader.java:307

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.

at java.lang.ClassLoader.loadClass(ClassLoader.java:248

Could not find the main class: Practice.class. Program will exit.

无论我使用什么版本的答案,都会出现此错误,该怎么办?

但是,如果我在Eclipse中以“运行方式>运行配置->程序参数”运行它

10 12

10 14

100 200

我没有输出

我已经取得了一些进展,一开始我遇到了编译错误,然后是运行时错误,现在我得到了错误的答案,所以任何人都可以帮我解决一下这是怎么回事:

import java.io.BufferedReader;

import java.io.IOException;

import java.io.InputStreamReader;

import java.math.BigInteger;

public class Practice {

public static BigInteger calculateAnswer(String a, String b) {

BigInteger ab = new BigInteger(a);

BigInteger bc = new BigInteger(b);

return bc.subtract(ab);

}

public static void main(String[] args) throws IOException {

BufferedReader stdin = new BufferedReader(new InputStreamReader(System.in));

String line;

while ((line = stdin.readLine()) != null && line.length()!= 0) {

String[] input = line.split(" ");

if (input.length == 2) {

System.out.println(calculateAnswer(input[0], input[1]));

}

}

}

}

回答:

我终于得到了它,无论出于何种原因都被提交了13次,第14位“法官”接受了我的回答,这是:

import java.io.BufferedInputStream;

import java.util.Scanner;

public class HashmatWarrior {

public static void main(String args[]) {

Scanner stdin = new Scanner(new BufferedInputStream(System.in));

while (stdin.hasNext()) {

System.out.println(Math.abs(stdin.nextLong() - stdin.nextLong()));

}

}

}

以上是 如何在Java中读取多行输入 的全部内容, 来源链接: utcz.com/qa/428737.html

回到顶部